请选择 进入手机版 | 继续访问电脑版

sufangxu's Blog

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 58|回复: 0
收起左侧

[学习记录] 找不到版本为 (>= 1.0.0-preview1-27891) 的包 Microsoft.AspNetCore.Sign...

[复制链接]

1万

主题

1万

帖子

4万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
44825
发表于 2019-11-4 16:33:40 | 显示全部楼层 |阅读模式

错误描述:

下载ABP模板项目3.4.1的版本(当前最新版本),编译加载nuget包Microsoft.AspNetCore.SignalR时会报如下错误:

严重性     代码         说明         项目         文件         行     禁止显示状态

错误         NU1102   找不到版本为 (>= 1.0.0-preview1-27891) 的包 Microsoft.AspNetCore.SignalR

  - 在 nuget.org 中找到 3 个版本[ 最接近版本: 1.0.0-alpha2-final ]

  - 在 Microsoft Visual Studio Offline Packages 中找到 0 个版本   AbpBasic.Web.Host         D:projectsdevabpsrcAbpBasic.Web.Hostabp.Web.Host.csproj     1      

20171229221559170434.png

错误分析:

通过对错误信息分析,在nuget.org里面没有Microsoft.AspNetCore.SignalR >= 1.0.0-preview1-27891的版本,由于abp采用的是开发预览版本,所以nuget.org还没有更新

解决方案:

Github已经有人提过此issue并得到了解决:https://github.com/aspnetboilerplate/aspnetboilerplate/issues/2831

Add this file to the same folder as your .sln file: NuGet.Config

            

这里只需要在vs 工具->选项-> NuGet包管理-> 程序包源 添加aspnetcore开发包的源:https://dotnet.myget.org/F/aspnetcore-dev/api/v3/index.json

然后再重新编译加载就可以了

20171229221559359855.png

20171229221559415510.png

然后重新编译项目成功!!!






上一篇:dotnet build
下一篇:The specified framework 'Microsoft.NETCore.App', version '1.0.1' was not foun...
往往并不是有兴趣才能做好,而是做好了才有兴趣。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|sufangxu's Blog ( 鲁ICP备17022854号-3 )

GMT+8, 2019-11-13 03:14 , Processed in 0.100391 second(s), 25 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表